ASUS Xonar D2X

Despite the enormous number of features that this card has, I have also run into an enormous number of issues with it. Here’s a list, just in case anyone is considering purchasing this card… hopefully this will help you avoid the pain and trouble I’ve been through (especially if you have a similar setup as me). My setup is currently Xonar D2X > QED Coaxial > Logitech Z5500.

With this in mind, the list:

  1. Initially, on boot up, the D2X refuses to output any audio. Under “Playback Devices”, “S/PDIF Pass-through Device” shows that there is audio (levels going up and down) when playing a music file; however, the Xonar D2X Audio Center shows no audio being output… and the Z5500 shows “No Digital Data”.
    ASUS Xonar D2X CP + S/PDIF Playback Devices

    ASUS Xonar D2X CP + S/PDIF Playback Devices

    I’ve found the only way to “fix” this issue is to play a file with a digital track (DTS or DD) in VLC with audio device set as “A/52 over S/PDIF”. After doing this, the Xonar D2X performs exactly as (I think) it should – all audio is passed through properly.

  2. After a few reboots, this was no longer the case… the sound was then outputting normally without ANY changes to settings and without playing a digital track upon boot-up. Ahh… inconsistent issues… the best type to troubleshoot.
  3. A few days later, I notice when watching Dexter, Mr Morgan’s voice seem strange. It turns out, after outputting digital audio DTS/DD (A/52 over S/PDIF), upon returning to normal “analog” audio via the coaxial output (optical not tested), all audio appears to increase in pitch slightly – becomes apparent when in voices (male voices become unusually high and almost female like, and female voice increase further). Again, ALL audio is affected; music in all players, audio from video files, YouTube, etc. Only solution I have found at this time is a REBOOT.
  4. There is occasional audio “lag” that I have been unable to figure out the cause. Example: Skype message comes in, seconds later, the Skype message TONE plays. This “appears” to occur across System sounds in general – games are not affected, although video could be (not double checked yet – could be just the video file with sync issues).

On top of all the issues I’ve faced in the week++ I’ve had this card, I’ve attempted to contact ASUS to see if they have any fixes/ideas… I have 2 open tickets and no responses since approximately 1 week ago. ASUS hardware quality may be good, but it sure looks like their support is an absolute crapstorm. It’s sad that the D2X is essentially the ONLY PCI Express sound card available with coaxial output. My main reason for wanting coaxial out is to make use of my QED coaxial cable (the Z5500 optical port is used for the PS3)… but based on the amount of crap I’ve had to put up with from the D2X, I’m probably going to return it and live with my onboard audio and switching optical cables between my PC and PS3.

The fact that the ASUS support forum is now essentially a marketplace for “performance enhancing drugs” doesn’t help whatsoever. ASUS representatives appear to drop in once a year (kind of like Santa) and post some random thing they figured out, before disappearing into the darkness. There seems to be no “support” whatsoever on the “support” forum.

Last time I’m buying any ASUS product. Good riddance.

UPDATE: This is the very much delayed reply from ASUS Support –

Dear Valued Customer,
Thank you for contacting ASUS Customer Service.
I? sorry that we have just received your letter due to our mail system errors.
Sorry for my delayed replying.
May I ask whether or not the problem has be solved yet?
If the problem still exists after you did all basic troubleshooting, please contact with your retailer for check. If the card is faulty, they will arrange RMA service for you.

Dear ASUS…

1) You need to get someone with a brain to setup your mail system.
2) Do you think waiting long enough will magically solve issues with your card?
3) I’d rather not have to send back a BRAND NEW card for RMA…

In summary, I’ve returned the Xonar D2X… and I am NEVER buying an ASUS product again.

2 thoughts on “ASUS Xonar D2X

  1. I know this is old but but ill reply anyway Dude there was nothing wrong with the card. Couldnt believe asus didnt tell you this basically if you connect your cad via digital it bi passes the sound card and doesnt use the sound card.If you buy a soundcard you DONT connect it via digital cos as you see its a waste. Cos it will by pass the sound card only time you connect it is if you wanna use dolby etc . The correct way to connect it and use the sound card was to use the 6 channel input cables that came with the z5500 and connect it that way. And yeah the customer service is pretty bad. But you returned a practily good card

Leave a Reply